omputers can be created individually with the corresponding parameters or they can be imported into the Empirum database.

This is how you create a new computer:

  1. Select the menYou can create computers individually with the corresponding parameters or import themu File > New Computer... or Right-click on Computers, one of the filters (e.g. Unassigned Computers) or an already created computer and in the context menu select New Computer... or right-click on a group and in the context menu select New > New Computer…

    If a computer is created in a group via the context menu, then the respective computer is directly assigned to the group and is displayed in the filter Assigned Computers. Otherwise it will be displayed in the filter Unassigned Computers and has to be manually assigned to the desired group.

    The New Computer dialog box appears.
  2. Specify the parameters of the computer / server you want to add and confirm your entries with OK.

General tab

Identity

Contains the most important parameters that allow you to define the computer. The following parameters are details that must be filled:

Computer Name

The Windows computer is specified in this field.

The computer name may contain the letters A-Z, the digits 0-9, hyphens (-), and dot (.) separators. The length must not exceed 15 characters.

Inventory ID (Optional)

Is a freely selected string for identification within an enterprise.

UUID

System Management BIOS Universal Unique Identifier (SMBIOS UUID) - also called GUID or UUID or SMBIOS GUID, is located on the motherboard of the device as an identification feature and is used for its unique identification. A UUID (12345678-0123-5678-0123-567890123456) consists of 36 characters, 4 of which are hyphens.

The SMBIOS UUID must be in the correct format when typing: Some systems pass the SMBIOS UUID in a rotated, the so-called Raw byte order (eg VMWare). Then the SMBIOS UUID must be converted into the so-called Pretty Print Format. The OS installation using EPE4 automatically detects the format of the SMBIOS UUID.

Example of the output of the UUID on a Windows client per cmd: wmic path win32_computersystemproduct get uuid

As of Empirum v18.0, the SMBIOS UUID is used instead of the MAC address for the operating system installation. The UUID is automatically entered in the computer properties after the first PXE boot process or by Empirum Inventory.

If there is a valid UUID and the MAC address, the UUID is used as the higher-order identifier. If there is no or an invalid UUID, the MAC address will be used as before.

The main advantage of the SMBIOS UUID is that when using a docking station or a USB to Ethernet adapter, despite always the same MAC address, but different device UUID's, the corresponding device can be clearly identified and installed.

Possible sources of error:

  • Some manufacturers always use the same SMBIOS UUID (contrary to the specification) for different device types, so you can enter such UUIDs as "Invalid" via EMC> Configuration> Boot Configurations> Tools menu> Invalid UUIDs. The MAC address is then the unique identification criterion for the affected devices.
  • There is also the option of using only the MAC address as a unique identification criterion - with all the disadvantages of using docking stations or USB to Ethernet adapters - the same MAC address is always used for different devices!

MAC Address (MAC = Media Access Control)

Is used to assign operating system configurations and allows network adapters to be uniquely identified worldwide. It is stored on the network card. The addresses are made up of 48 bits. They are represented as 6 hexadecimal numbers (example: 00-30-67-34-00-1A).

The first three hexadecimal numbers specify the manufacturer code. The remaining numbers are internally used for encoding.

PXE enabled

Here you can directly specify if the new computer is PXE-enabled. It is not necessary anymore to specify it as PXE-enabled through the PXE boot process (grey activation status).

Under certain circumstances, setting the PXE capability of a computer is not allowed. The reason for this is that the PXE service must uniquely identify a PXE-enabled computer at boot by its MAC address and UUID in order to assign the correct PXE image to it.
If the PXE capability is to be set on a computer, then there must be no other PXE-capable computer whose MAC addresses and UUID combination means that a computer can no longer be uniquely identified.
The UUID is preferred for identification. Exceptions are UUIDs that have been flagged as invalid and have been included in the list of invalid UUIDs. In these cases, the MAC address must be unique to identify a computer.
The following table gives an overview of when setting the PXE capability on a computer is allowed or disallowed.

Existing Computer New Computer
UUID MAC PXE capable UUID MAC PXE capable allowed
UUID1 MAC1 Yes UUID2 MAC2 GruenerHaken_16x16 Yes
UUID1 - Yes UUID2 - GruenerHaken_16x16 Yes
- MAC1 Yes - MAC2 GruenerHaken_16x16 Yes
- MAC1 Yes invalid MAC2 GruenerHaken_16x16 Yes
invalid MAC1 Yes - MAC2 GruenerHaken_16x16 Yes
invalid MAC1 Yes invalid MAC2 GruenerHaken_16x16 Yes
UUID1 MAC1 Yes UUID2 MAC1 GruenerHaken_16x16 Yes
- MAC1 Yes - MAC1 RotesX_16x16 No
invalid MAC1 Yes - MAC1 RotesX_16x16 No
- MAC1 Yes invalid MAC1 RotesX_16x16 No
UUID1 MAC1 Yes - MAC1 RotesX_16x16 No
UUID1 MAC1 Yes invalid MAC1 RotesX_16x16 No
UUID1 = A valid UUID that is different from UUID2.
UUID2 = A valid UUID that is different from UUID1.
MAC1 = A valid MAC address that is different from MAC2.
MAC2 = A valid MAC address that is different from MAC2.
- = No value specified.
invalid = UUID is included in the list of invalid UUIDs and is not used for identification.
Legend

Workgr./Domain

A domain/workgroup is made up of several computers, which were assigned a shared group name. A domain consists of shared resources and their users.

Domain

Specify whether the computer belongs to a domain. A domain is made up of several computers, which were assigned a shared group name.

FQDN (Optional)

The FQDN value specifies the "Fully Qualified Domain Name" without host name. Example: The computer name PC0815 and the FQDN value matrix42.com are used as pc0815.matrix42.com for internal name resolution. The value can be set as default value in variables of the configuration or assignment groups or directly on the computer.

In the background, the value also serves as normal Empirum variable and can also be used for software packages. Empirum uses the value during operating system installation and to connect to third-party systems such as vCenter or XenDesktop servers.

Overwrite

If a computer with a predefined FQDN entry is to be created / reinstalled, this option must be activated (check mark). This entry will then no longer be overwritten by Empirum Inventory.

OU (Optional)

The OU value specifies the container of the computer object in Active Directory. Empirum uses the value during operating system installation and to create virtual desktops. This value is also used for Service Store integration as additional grouping for assignment groups.

During operating system installation this value overrides the value specified in the template.

Use default OU

If this option is enabled, a new computer to be installed is added in the Microsoft Standard OU "CN=Computers" (users in the Microsoft Standard OU "CN=Users"). If you do not want this, the OU object must be defined for each client - e.g. "OU=Desktops,DC=QAlab,DC=Matrix42,DC=en". Only the standard OU's are globally defined here.

IP Address (appears only when configured via Static)

Select this option if the computer obtains its IP address from a DHCP server. If you click Static...the TCP/IP Properties dialog box will appear. Here, you can enter additional IP addresses, DNS servers and WINS addresses for a computer.

  • IP Address: Specify the IP address assigned to this computer. An IP address is made up of 4 numbers (between 0 and 255) which are separated by dots.
  • Subnet Mask: Specify the appropriate subnet mask. Together with the IP address, the subnet mask defines the network segment in which the computer is located.
  • Default Gateway: Enter the IP address of the default gateway via which data is transmitted to other networks and sub-networks.

If you do not specify the IP address of the default gateway, you restrict the IP functionality to the local sub-network.

DHCP

Select this option if the computer gets its IP address from a DHCP server. DHCP (Dynamic Host Configuration Protocol) allows the dynamic assignment of IP addresses.

Last seen

Here you can see the time of the last registration on the server. Each time a computer updates its software or status logs, this value is updated with the time in the log. It is also possible to filter by the time of the last registration.

Computer Type

Hardware type

Used to specify the type of the new computer. If virtual hardware is specified as hardware type, the "Hosting Infrastructure Data" tab will be displayed automatically. This tab is used to select the hosting infrastructure and the template name to which the computer shall be assigned.

Inventory determines the computer type automatically, based on various criteria, and changes it accordingly. You can use the Inventory service option Merge Inventory - Computer in DBUtil to disable this feature. Existing computers of the Empirum Server type will never be modified automatically.

OS Type

Select the installed operating system type.

Computer role

Used to specify computer properties that provide information on the roles (properties and tasks) of a computer and are used for Empirum-internal management purposes, e.g. Empirum depot server role. The VDI tab is only displayed if you either select Computer Type > Computer Role > Connection Broker or Computer Type > Computer Role > XenDesktop Provisioning Server in the General tab. The Hosting Infrastructure tab is only displayed if you select as hardware hype Virtual Hardware in the General tab.

Additional Information

Double-click an entry to bring up a dialog box where you can enter the desired values. Your entries will then be displayed on the right side of the dialog box.

The fields have to be defined under Tools > Properties > Additional Information beforehand.

Defining Additional Information

To create additional information, proceed as follows:

  1. Select the menu Tools > Properties..., or click the Einstellungen toolbar icon.
    The Properties dialog box appears.
  2. Select the Additional Information tab.
  3. In the left column called Available free fields, double-click a free field, e.g. Custom09.
    The Edit Value dialog box appears.
    Manager_015
  4. Enter your text under Description, e.g. ComputerID, and confirm with OK.
    Your text now appears next to the field Custom09 in the left column Available free fields. To be able to edit the field under Additional Information in the Add new Computer... dialog box, you have to enter it into the right column Order of additional information.
  5. To do so, select the field with the new description, e.g. Custom09, ComputerID and click the green plus sign in the middle of the dialog box. The arrows allow you to change the order of the fields.